nixos-config/common/default.nix
2024-10-19 14:41:43 +02:00

60 lines
1.5 KiB
Nix

{
config,
lib,
inputs,
pkgs,
...
}: {
imports = [
./syncthing.nix
./sops.nix
];
#nixpkgs.config.permittedInsecurePackages = ["electron-25.9.0" "electron-24.8.6"];
networking.hosts = {
"192.168.178.35" = ["jellyfin.fritz.box" "grafana.fritz.box"];
};
users.users.xqtc.openssh.authorizedKeys.keys = ["ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIN7UkcmSVo+SeB5Obevz3mf3UHruYxn0UHUzoOs2gDBy xqtc@heroin.trade"];
users.users.root.openssh.authorizedKeys.keys = ["ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIN7UkcmSVo+SeB5Obevz3mf3UHruYxn0UHUzoOs2gDBy xqtc@heroin.trade"];
# environment.systemPackages = with pkgs; [
# xdg-desktop-portal-hyprland
# xdg-desktop-portal
# ];
programs.nh = {
enable = true;
clean.enable = true;
clean.extraArgs = "--keep-since 4d --keep 3";
flake = "/home/xqtc/nixos-config";
};
networking.firewall.allowedTCPPorts = [8384 22000];
networking.firewall.allowedUDPPorts = [22000 21027];
nix.package = pkgs.lix;
environment.systemPackages = with pkgs; [
sops
tldr
screen
zsh
inputs.compose2nix.packages.${pkgs.system}.default
];
programs.zsh.enable = true;
programs.nix-ld = {
enable = true;
package = pkgs.nix-ld-rs;
};
services.tailscale.enable = true;
nix.settings = {
trusted-users = ["xqtc"];
substituters = [
"https://nix-community.cachix.org"
];
trusted-public-keys = [
"nix-community.cachix.org-1:mB9FSh9qf2dCimDSUo8Zy7bkq5CX+/rkCWyvRCYg3Fs="
];
};
}